苹果要求明年6月起应用须支持64位硬件

近日,苹果公司发布公告称,要求从明年6月份开始已上架的应用也要升级至支持64位硬件。其实早在今年10月,苹果公司就发布公告要求明年2月起所有新应用必须支持64位硬件才能上架,但没有在公告中对已上架的应用进行要求。

【GameLook专稿,转载请注明出处】

GameLook报道 / 近日,苹果公司发布公告称,要求从明年6月份开始已上架的应用也要升级至支持64位硬件。其实早在今年10月,苹果公司就发布公告要求明年2月起所有新应用必须支持64位硬件才能上架,但没有在公告中对已上架的应用进行要求。

苹果公司公告大意:我们在今年10月的时候就宣布,自2015年2月起提交到AppStore的应用程序必须支持64位版的iOS 8 SDK。而2015年6月1日起,所有应用程序也将遵循上述规定。为了方便搭建64位应用,我们建议您在Xcode默认设置‘standard architectures’下进行搭建,这样可以保证应用程序同时兼容32位和64位。

据悉,目前支持64位软件的苹果设备包括iPhone 5S、iPhone 6、iPhone 6 Plus、iPad Air、iPad Air 2、iPad mini 2、iPad mini 3,支持64位的处理器包括A7、A8、A8X。对于苹果来说,64位处理器的芯片已经成为趋势,如果适配32位应用,就需要经过转译运行,而这无形之中将会产生性能损耗。

如若转载,请注明出处:http://www.gamelook.com.cn/2014/12/195329

发表评论

电子邮件地址不会被公开。

关注微信